Data Capture Lab (Windows)

Current Release

2020.7.3 (09/23/2020)

What’s New

  • Minor improvements to enhance user experience

Bug Fixes

  • Fixed issue where sometimes project upload status was not getting refreshed

Past Releases

2020.7.2 (09/17/2020)

What’s New

  • Updated Starter Edition to no longer have a license time limit. Note: Starter Edition is limited to 2500 segments per project and must be logged in to add new data to a project

2020.7.1 (08/19/2020)

What’s New

  • Added sample rates 210hz, 400hz, and 600hz to QuickFeather data collection options. Note: The MC3635 accelerometer in QuickFeather has a +/- 10% tolerance in the internal clock used to set sample rate. This means setting a sample rate of 400Hz can result in captured sensor data varying from board to board within a range of 360Hz – 440hz. This sensor limitation should be understood and factored in your models for applications where sample timing sensitivity is critical.

2020.7.0 (08/12/2020)

What’s New

2020.6.1 (07/20/2020)

Bug Fixes

  • Fixed issue with sensors not loading correctly in sensor configuration screen

2020.6.0 (07/15/2020)

What’s New

  • Added ST SensorTile.Box as a supported platform for data collection

  • Added the ability to use external third-party devices for data collection within the Data Capture Lab. For more details on this feature, see the following tutorial: How to Import a Device Plugin

2020.5.0 (05/26/2020)

What’s New

  • Performance Improvements - Added improvements to saving/uploading metadata and segments in the following areas of the DCL (up to 20x-100x faster depending on your project size)

    Upload project

    File Import -> DCLI format

    File Import -> QLSM format

    Open Capture -> Metadata Add/Update/Delete

    Open Capture -> Segment Add/Update/Delete

    Open Capture -> Detect Segments

    Project Explorer -> Copy Segments

    Project Explorer -> Copy Session

    Project Explorer -> Edit Metadata

    Auto Sync -> Syncing offline metadata/segments with the server

    Auto Sync -> Syncing server metadata/segments with your local machine

  • Added ability to load/save segments in Auto Sessions offline

  • Added new graphing tool called Segment Width Lock. The Segment Width Lock toggle gives you the ability to lock the segment width during location placement so that you can move an entire segment at one time instead of just the start or end of the segment

../_images/segment-width-lock.png

Bug Fixes

  • Fixed issue where the Max Capture Time setting would sometimes show an error in Capture mode when auto-saving sensor data over BLE streaming connections

2020.4.0 (05/04/2020)

What’s New

WAV File Updates

  • Added support for WAV file upload/download on SensiML Servers

  • Added multi-channel support on WAV files

  • Note: WAV file updates are only supported in new projects created with DCL v2020.4.0 or later

Performance Improvements

  • Added improvements to load times in the following areas (up to 20x faster depending on your project size)

    Project → Download

    Project → Open

    Project → Sync

    Capture File → Open

Find Capture By UUID

  • Added option to lookup a capture by UUID in menu item Edit → Find

../_images/find-capture-by-uuid.png

Bug Fixes

  • Fixed issue with Session → Delete not refreshing segment totals in Project Explorer

  • Minor stability fixes

2020.3.1 (04/14/2020)

What’s New

  • Added format selection screen to DCLI file import

../_images/import-selection.png
  • Added new validation checks to DCLI file import

  • Updated UX for all import file options to be more intuitive

  • Added a cancel button to File → Upload progress dialog

  • Added option to lookup a segment by UUID in menu item Edit → Find

../_images/find-segment-by-uuid.png

Bug Fixes

  • Fixed issue with renaming Project Property labels with different letter casing

  • Fixed issue with switching to Label mode in the middle of recording a file in Capture mode

  • Minor stability fixes

2020.3.0 (03/02/2020)

What’s New

  • Added feature to export metadata/segments into .dcli file format

    This can be found in the Project Explorer: Select a list of files → Right + Click → Export

  • Added feature to import auto sessions via .dcli format

  • Updated Project Properties → Segment Labels tab to show segment labels by default instead of segment groups. In order to change this back to show segment groups open the Advanced tab and click Enable segment label groups

  • Improved Copy Segments performance

  • Updated SaaS license agreement

Bug Fixes

  • Fixed project sync issue where sometimes loading capture files would fail

  • Fixed threading issue with Save Changes button

  • Fixed issue where disabling Import → Index column setting would sometimes not work correctly

  • Fixed issue where deleting Project Properties offline would sometimes not work correctly

  • Fixed issue where uploading a project via Project Upload would sometimes not clear dependencies correctly

  • Minor stability fixes

2020.2.0 (02/06/2020)

What’s New

Import Upgrades

  • Added feature for importing metadata and segments from outside sources via a new file format (.dcli)

For more details see the Importing External Sensor Data tutorial

../_images/import-from-dcli1.png
  • General usability improvements

  • Minor UI improvements

Bug Fixes

  • Fixed issue with track settings sometimes not saving

  • Minor stability fixes

2020.1.0 (01/14/2020)

What’s New

  • Capture mode - Added support for MQTT-SN data collection with QuickAI

Bug Fixes

  • Fixed issue with collecting data from QuickAI and Chilkat when Windows language setting is not set to English

  • Fixed issue with selected files in the Project Explorer changing when switching between Capture and Label mode

  • Minor stability fixes

2019.5.0 (12/10/2019)

What’s New

Project Explorer Upgrades

../_images/project-explorer.png
  • Added metadata columns to the project explorer

  • Added ability to sort files by metadata column

  • Moved Import Files button to menu File → Import Files

  • Moved Project Properties button to menu Edit → Project Properties

  • Added a status window when deleting files

  • Improved performance of Import and Delete operations on files

  • Added selected file count to the project explorer

../_images/project-explorer-files-selected.png
  • Added the ability to group by metadata columns

../_images/project-explorer-group-by-metadata.png
  • The group by metadata feature can be found in Project Explorer → Preferences

../_images/project-explorer-preferences.png
  • Added Expand all/Collapse all button for expanding/collapsing metadata groups

General Updates

  • Added Keyboard Shortcut screen. This can be found under menu Help → Keyboard Shortcuts

  • Added a progress bar for longer file operations (File upload, download, delete, sync)

  • Added subscription tier to startup screen

  • Minor bug fixes

2019.4.3 (11/20/2019)

Bug Fixes

  • Fixed issue where importing external CSV files would fail in some scenarios

  • Minor bug fixes

2019.4.2 (11/19/2019)

Bug Fixes

  • Fixed issue with uploading WAV files

  • Minor bug fixes

2019.4.1 (11/16/2019)

Bug Fixes

  • Minor bug fixes

2019.4.0 (11/12/2019)

What’s New

Project Architecture Updates

  • Refactored project architecture

- .dclproj files created before v2019.4.0 will be upgraded to the new format when you open your project. A backup of your original .dclproj file will be saved to your computer

- .dcl, .sdcl, label.config, and builder.dclseg files were deprecated with this update. These files will also be backed up when you convert your .dclproj file to the new format, but they are no longer used

  • General performance improvements

  • Changed behavior of project properties screen. Adding, updating, or deleting project properties now updates the entire project

Project Explorer Menu Options

../_images/project-explorer-right-click.png
  • Added the ability to compare multiple files in the same graph

  • Added the ability to edit metadata from Project Explorer

  • Added the ability to copy segments from multiple files to another session

  • Added the ability to use selected files to find a segmenter algorithm by using the Generate auto session button

  • Segment totals are now based on the current session

  • Segment totals now include offline segments

Session Menu Options

../_images/project-explorer-session-options.png
  • Added the ability to create a new copy of a session

  • Replaced Segmenter Builder mode. You can now use any existing session as your training data set. Click Generate auto session inside the Project Explorer to use a session for finding a segmenter.

  • Added the ability to view all files that have been labeled in a session together in the same graph

General

  • Switching video file views retains the previous video position

  • Video file locations are now saved as relative paths instead of absolute paths

  • Added an expand track button to the graphing tool

  • Enabled data collection for AD7476 on QuickAI

2019.3.2 (10/22/2019)

What’s New

  • Created a read-only version of DCL for opening and viewing project data sets without an active subscription. This version cannot create or modify projects

  • Added a checkbox to the Import Files screen to disable auto-upload

2019.3.1 (09/24/2019)

What’s New

  • Added ability to sort columns in the project explorer

  • Added ‘MagnitudeAllColumns’ transform to the auto-session parameters

  • Moved capture collection methods dropdown into the main Capture window

Bug Fixes

  • Fixed issue with opening a project that contained a session where the segmenter no longer exists

2019.3.0 (07/30/2019)

What’s New

  • Capture mode - Added new supported capture device SensorTile

    Supported Frequencies: 26hz, 52hz, 104hz, 208hz, 416h

2019.2.3 (07/18/2019)

What’s New

  • Added ability to set max record time limit in Capture mode. This setting can be found in the main DCL Settings → Max Record Time

Bug Fixes

  • Fixed issue with Session → Clear button not clearing empty segments

  • Fixed issue with Session → Detect button not clearing empty segments

2019.2.2 (07/02/2019)

What’s New

  • Added ability to save metadata properties on files recorded via QuickAI SD card

    Note: Must import .qlsm files through the project where the files were captured

  • Added ability to lock Y-Axis range and set Y-Axis minimum and maximum bounds

../_images/set-y-axis.png
  • Deprecated SegmentID labels. This speeds up Create/Update/Delete actions by 2x on Segment modifications

  • Added clear error message for expired login credentials

Bug Fixes

  • Minor stability fixes

2019.2.1 (06/18/2019)

What’s New

  • Moved Label Config tab to Project Explorer → Project Properties screen

  • Updated metadata and label configuration UX to be more intuitive

  • Added ‘Segments on Cloud’ feature to the Project Explorer. This shows the total number of segments in a capture file

  • Added a segment length property shown above the graph in the Label Explorer

Bug Fixes

  • Fixed off-by-one error in ‘Default Segment Length’ setting

  • Minor stability fixes

2019.2.0 (06/11/2019)

What’s New

  • Added support for capturing sensor data from QuickLogic Chilkat devices

Bug Fixes

  • Fixed issue with QuickAI device not releasing resources correctly on BLE disconnect

  • Fixed display issue on capture sensor configuration screen

2019.1.2 (05/21/2019)

What’s New

Project Explorer Upgrades

  • Added ability to select multiple files in the Project Explorer

  • Important Behavior change (Open File) → To open a file in the project explorer double click the file name

  • Added ability to Upload, Download, and Delete multiple selected files at the same time

  • Right-Click on a file name in the Project Explorer to see Upload, Download, and Delete menu options

  • Moved ‘Upload Files To Cloud’ button into the project explorer menu options (Upload)

  • Moved ‘Download Files From Cloud’ button into the project explorer menu options (Download)

  • New keyboard shortcuts in Project Explorer:

    SHIFT + Click

    Select multiple consecutive files

    CTRL + Click

    Select multiple non-consecutive files

    CTRL + A

    Select all files

Import File Screen

  • Added check/conversion options for Signed/Unsigned data from .qlsm files

Bug Fixes

  • Fixed localization error with saving estimated (calculated) sample rate during capture mode

  • Added validation rules to label configuration screens

2019.1.1 (05/08/2019)

What’s New

  • Added a max file size limit while recording in capture mode

  • Added max throughput configuration check for Mayhew LTC1859

  • Removed unsupported Mayhew LTC1859 channel configuration parameters (0-5V Single-Ended, 0-10V Single-Ended, 0-5V Differential, 0-10V Differential)

Bug Fixes

  • Fixed error with restarting QuickAI device while recording in capture mode

  • Fixed scenario where ‘Device’ metadata property was sometimes cleared

2019.1.0 (05/05/2019)

What’s New

  • Capture mode - Enabled high frequency sample rates on QuickAI (208, 416, 832, 1660)

    Note: High frequency sample rate files are saved to SD card

  • Capture mode - Enabled Audio on QuickAI

    Note: Audio files are saved to SD card

  • Capture mode - Enabled Mayhew LTC1859 on QuickAI

    Note: Mayhew LTC1859 files are saved to SD card

  • Added new supported file type (.qlsm)

  • Added ability to create multiple sensor configurations on a project

  • Added ability to set sensor configurations when importing external files

  • Updated sample rate to be pulled from sensor configurations

Bug Fixes

  • General stability improvements to capture mode

2.5.0 (04/10/2019)

What’s New

Multi-Sensor Graphing

../_images/multi-sensor-graphing.png
  • Added ability to split sensor data columns graph into multiple tracks

  • Added ability to change graph height

  • Added ability to change order of tracks

  • Added ability to trim the start/end points in a CSV or WAV file

Media Player Updates

../_images/media-player-update.png
  • New UX for media player

  • General stability improvements

  • Added option to Float / Dock media player

  • Added time display for current sensor data location

  • Added time display for video location and total video length

  • Added ability to trim the start/end points in a video file

  • Added keyboard shortcuts for media playback

    Spacebar

    Play/Stop video or audio file

    Right Arrow

    Step forward 1 frame

    SHIFT + Right Arrow

    Step forward X frames (set in DCL settings screen)

    Left Arrow

    Step backward 1 frame

    SHIFT + Left Arrow

    Step backward X frames (set in DCL settings screen)

Multiple Manual Segmenters (Sessions)

../_images/multiple-manual-sessions.png
  • Added ability to create multiple manual segmenters

  • Added ability to customize manual segmenter names

  • Added ability to use Delete/Clear buttons with manual segmenters

  • Added new button ‘Copy’ to copy segments from one segmenter to another

  • Added option in Capture mode to select a segmenter session while capturing files

General Updates

  • Added better support for low screen resolutions

  • Added display for total sensor file length

  • Added File → Close File menu option

  • Added Help → Check for Updates menu option

  • Moved sample rate control into the Metadata tab

  • Moved toggle for packet loss annotations into DCL application settings

  • Minor UX improvements

Bug Fixes

  • Fixed issue in capture mode where last used device would sometimes fail to connect

  • Fixed issue in capture mode with estimated sample rate not being saved

  • Fixed issue in Open Project screen where project names that have an underscore were not displaying properly

  • Fixed issue in Label Mode with Segment Overview Control sometimes not displaying labels

  • Other minor bug fixes

2.4.0 (02/26/2019)

What’s New

  • Capturing audio data on Nordic Thingy now saves to WAV instead of CSV

  • Enabled QuickAI low frequency sample rates (26hz, 52hz)

  • Improved performance of Auto-Segmenters in DCL

  • Added support for upcoming server release

Bug Fixes

  • Fixed an invalid parameter in some auto-segmenter algorithms

  • Fixed sample rate when capturing Nordic Thingy audio (Changed from 8kHz to 16kHz)

  • Fixed issue when resolving a merge conflict between two labels would sometimes not save the segmenter

  • Fixed issue with creating a custom project schema while importing external captures files that have a ‘sequence’ column

  • Added user friendly error message for files with corrupted sensor data in a row

2.3.0 (09/26/2018)

What’s New

Major Features

  • Added a timer while recording sensor data in Capture mode

  • Added a service to check for the latest version on startup

Minor Features

  • Updated ‘Sensor Select’ in the graphing control to always remember the last selected sensor columns

  • Changed the default behavior for labeling multiple file metadata and segments

Bug Fixes

  • Fixed bug with ‘Auto add label’ checkbox on the segment label screen not always remembering the last selected label

  • Fixed bug that sometimes causes an error when switching out of Capture mode while recording

2.2.1 (09/10/2018)

Bug Fixes

  • Fixed issue where QuickAI sample rate metadata was saved as 100hz instead of 104hz

2.2.0 (08/30/2018)

What’s New

Major Features

  • Added new supported device - QuickAI

  • Added feature to remember the last connected device in Capture mode

  • Refactored device plugin architecture

  • Added new feature in the Project Explorer for importing external sensor data files into the DCL

Minor Features

  • Added ‘Open in Explorer’ option when you right-click on a file in the Project Explorer. This opens the selected file in Windows Explorer

  • Moved ‘CSV Time Column’ and ‘Sample Rate’ settings from the Application Settings screen into the new import settings screen. These settings are used when importing external files to a project

  • Removed relative ‘CaptureFiles’ paths from the .dclproj file. The DCL now automatically loads all files in the /data/ directory

  • The Label Config screen now trims extra white space from the end of labels to ensure consistent labeling

Bug Fixes

  • .WAV column name updated from ‘Channel_0’ to ‘Microphone’. When collecting audio files through the DCL the column was saved as Microphone, but if you opened a .WAV file the column would load as ‘Channel_0’ which caused a mismatch on the server

  • Fixed minor issue where sometimes the plugin configuration would not load correctly, causing the ‘Save Changes’ button to appear even though there were no changes made

  • Fixed issue where vertical videos would playback in horizontal mode

  • Removed unsupported sensors from Nordic Thingy data sensor configuration screen

2.1.5

What’s New

  • Added signing certificate to installer

2.1.4

What’s New

Minor Features

  • Combined the Activity/Metadata tabs on the capture screen

  • Updated desktop DCL icon to match mobile DCL icon

  • Added ability to set ‘Default Segment Length’ when you add a segment via single right click on the graph

Bug Fixes

  • Fixed issue with adding a new segmenter algorithm when there are unsaved segment changes

2.1.3

Bug Fixes

  • Fixes null exception while opening an offline project

2.1.2

What’s New

Major Features

  • Device plugin configuration is now saved to the cloud

Bug Fixes

  • Fixed issue in the Project Explorer where ‘Try again’ upload option would appear on files that have not been linked locally

2.1.1

What’s New

Major Features

  • Added support for capturing audio data from Nordic Thingy

    Note: Currently saves raw data in CSV format

Minor Features

  • Added ability to rename capture files in the project explorer

  • Updated remove capture feature to delete capture in the project explorer

Bug Fixes

  • Fixed issue with extra fields being saved to segment file (NoBinding fields)

2.1.0

What’s New

Major Features

  • Added Nordic Thingy as a supported capture device

  • Created new ‘Open Project’ screen

  • Added ‘Recent Projects’ list feature. The DCL remembers the most recently opened projects to allow for quick access the next time opening the DCL

  • Added ‘Remember me’ capability to the login screen

  • Added ability to use Magnitude transforms on auto-segmenter columns

Minor Features

  • Updated capture mode to automatically adds files to a project

  • Updated capture mode to use the label configuration

Bug Fixes

  • Fixed issue with Toast notifications appearing on wrong monitor if PC is docked to multiple monitors

2.0.2

What’s New

Minor Features

  • Save project from cloud now saves the label configuration

  • Added better error messages when deserializing label configuration

2.0.1

What’s New

Major Features

  • Added ability to download project and capture data from cloud to local hard drive

Minor Features

  • Added ability to clear auto-generated segments on a capture file

Bug Fixes

  • Fixed display issue with video playback

  • Fixed unexpected error when clicking on segment line inside the Segmenter Builder

  • Fixed issue with empty .sdcl files

2.0.0

What’s New

WAV File Support

  • Added ability to add .WAV files to a project

  • Added ability to segment and play .WAV files

  • Added ability to save a .WAV file as CSV

Auto Segmenters

  • Added ability to create multiple auto-segmenters for a project

  • Added ability to view segments generated by auto-segmenters

General Updates

  • Added Y-Axis to label mode graph

  • Created ‘Segmenter Builder’ feature - Allows user to select “ideal” segments to automatically find a segmenter for generating segments

  • Created Label Config - New feature for labeling Segments/Metadata. Makes typo errors less likely. Replaces ‘Default Labels/Default Metadata’

  • Created ‘Segment Overview’ - Allows user to quickly tab through segments on a file to see basic segment label summary

Minor Features

  • Segment double click - Added ability to double click on a segment to have the graph zoom into the segment

  • Adjust offset feature - Adds ability to drag the blue offset line to the correct location while playing videos

  • Cloud sample rate - Sample rate now is saved to both local captures and cloud captures

  • Calculated sample rate - New feature for keeping video files in sync with raw data

  • Loading capture file - Loading ‘Cloud only’ project files is now significantly faster

  • Uploading capture file - Uploading new files to the cloud is now significantly faster

  • Add video feature - Added buttons for for adding/removing a video to play with a raw capture file

  • Show packet loss gaps - Added a checkbox for making packet loss gaps visible as gray boxes in the graph

  • Show Line Point Markers - Added a checkbox to show exact sensor amplitude values when hovering over graph points

Limitations

  • Audio features - Audio must be in .WAV format, 16 bit, and 16 kHz sampling rate